Привожу инструкцию по настройке Cisco VPN Client на оборудование CISCO ASA 5505 или 5520 в ответ на комментарий в ранее написанной статье.
А вот и информация по настройке Cisco VPN Client между удаленным компьютером и CISCO ASA 5505 и ей подобным.

Исходные данные:

Транслируемые сети которые со стороны LAN интерфейса: 10.10.10.0/24 и 10.20.0.0/16
Внутренняя сеть для VPN клиентов 192.168.2.0/24
Шлюз в другие сети со стороны LAN: 192.168.1.10
IP адрес на интерфейсе со стороны LAN: 192.168.1.1
DNS и WINS сервер со стороны LAN (не обязательно): 192.168.1.5

Для работы VPN сервера на CISCO шлюз должен иметь белый адрес. Возможно и другие варианты, но тут они не описаны.

#conf t
!…
! Часть конфигурации (настройка интерфейсов) опущена
!…
! Позволяем работать ICMP (PING) запросам
access-list out_access_in extended permit icmp any any
! Какие сети транслируем в VPN
access-list 101 extended permit ip 10.20.0.0 255.255.0.0 192.168.2.0 255.255.255.0
access-list 101 extended permit ip 10.10.10.0 255.255.255.0 192.168.2.0 255.255.255.0
!
pager lines 24
mtu inside 1500
mtu dub 1500
mtu management 1500
! Пул DHCP адресов которые выдаются VPN клиентам
ip local pool IPPOOL 192.168.2.100-192.168.2.200
no failover
asdm image disk0:/asdm512-k8.bin
no asdm history enable
arp timeout 14400
!
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0
!
access-group out_access_in in interface outside
!
route inside 10.20.0.0 255.255.0.0 192.168.1.10 1
route inside 10.10.10.0 255.255.225.0 192.168.1.10 1
!
group-policy VPNCLNT internal
group-policy VPNCLNT attributes
wins-server value 192.168.1.5 192.100.1.101
dns-server value 192.168.1.5 192.100.1.101
vpn-idle-timeout 30
split-tunnel-policy tunnelspecified
split-tunnel-network-list value 101
default-domain value mydomain.ru
! Пользователи которые используются для логина через VPN Client
username MY_VPN_USER password MY_VPN_PASSWORD encrypted
!
crypto ipsec transform-set myset esp-aes esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface dub
isakmp identity address
isakmp enable dub
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp ipsec-over-tcp port 10000
tunnel-group VPNCLNT type ipsec-ra
tunnel-group VPNCLNT general-attributes
address-pool IPPOOL
default-group-policy VPNCLNT
tunnel-group VPNCLNT ipsec-attributes
! Пароль на группу VPNCLNT
pre-shared-key MY_VPN_PASSWORD_GROUP
!
!
class-map inspection_default
match default-inspection-traffic
!
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global

Вот вроде как и все, если нигде не напутал. Если что не работает – напишите, исправим, т.к. конфигурация взята с рабочего оборудования и изменены только пароли и IP адреса.

UPD: В следующем посте описана настройка Windows GUI клиента CISCO VPN Client